ドリトル

「ドクター・ドリトル(アフリカへゆく)」を読んでみました!大体の人が知っている名作です!
「動物と会話ができるなんていいな~」と思いました。ドリトル先生のような人が実際にいたら、その人は大金持ちです!もし僕にもペットがいて、そのペットが病気になったら、ドリトル先生の所に行きます!

「ドクター・ドリトル(アフリカへゆく)」を読んでみました!大体の人が知っている名作です! 「動物と会話ができるなんていいな~」と思いました。ドリトル先生のような人が実際にいたら、その人は大金持ちです!もし僕にもペットがいて、そのペットが病気になったら、ドリトル先生の所に行きます!

4
[ 雑記 ] 統計教育の方法論ワークショップに参加した話

[ 雑記 ] 統計教育の方法論ワークショップに参加した話

2日間、統計教育の方法論ワークショップに参加していました。 大学に限らず、小中学校、高等学校における実践を聞くことができて、とても面白かったです。スプレッドシートやR,Pythonだけでなく、「Simple Hist」や「科学の道具箱」など、統計教育に使用されるツールも知れたのが、収穫でした。 そういえば、ドリトルって統計機能が追加されていたよなーと思い、少し試してみました。 今回はTSVファイルを読んで、棒グラフを表示してみました。プログラムは以下のとおりです。 通

[ ドリトル ] m1でドリトルが動くか試してみた

[ ドリトル ] m1でドリトルが動くか試してみた

絶賛、mac mini の環境構築中です。 授業や研究で使用するドリトルが動作するか、試してみました。 次のサイトからパッケージ(v3.31)をダウンロードして実行。 動作しました。macにあった文字変換の際の不具合が修正されているようです。 新しいドリトル(3.31)を初めて使ってみましたが、背景が赤くなる機能は良さげですね。 年末に時間が取れたら、色々と触ってみたいと思います。

4
[ かめアート ] 六角形

[ かめアート ] 六角形

作品 概要 ・シェルピンスキーのギャスケットを六角形にして描いてみました。 ・オンライン版ドリトルを使用。 ・実行ごとに線の色が変化します。 ソースコード かめた=タートル!作る。かめた:六角形を描く=「|x y| 「  自分!(x) 歩く 60 左回り。 「y>0」!なら「 かめた!(x/2)(y-1)六角形を描く。 かめた!(色!255 (乱数(128)+30) (乱数(128)+30) 作る) 線の色。 」実行。 」!6 くり返す。」。画

[ かめアート ]
              
            シェルピンスキーのギャスケット

[ かめアート ] シェルピンスキーのギャスケット

作品 概要 ・オンライン版ドリトルを使用して、シェルピンスキーのギャスケットを再帰あり/なしで描いてみました。 ・実行ごとに線の色が変化するのが工夫点です。 ソースコード(再帰あり) かめた=タートル!作る。かめた:三角を描く=「|x y| 「  自分!(x) 歩く 120 左回り。 「y>0」!なら「 かめた!(x/2)(y-1)三角を描く。 かめた!(色!(乱数(128)+30) (乱数(128)+30) 255 作る) 線の色。

[ ドリトル ] タートルをサーバーに置いたイラストに変身させる

[ ドリトル ] タートルをサーバーに置いたイラストに変身させる

オンライン版のドリトルを使っていると、Webの画像が使えることがわかったので、2匹のタートルを変身させて遊んでみました。 <実行結果> // 準備中 <プログラム> かめた=タートル!作る "https://XXX1.png" 変身する 0.5 拡大する。かめきち=タートル!作る "https://XXX2.png" 変身する 0.5 拡大する。タイマー!作る「|x| 「(x%2) == 0」!なら「  かめきち!消える。かめた!現れる。 」そうでなければ「  かめき

左人差し指と右人差し指が対決する早押しゲーム

左人差し指と右人差し指が対決する早押しゲーム

自分の左人差し指と右人差し指のどちらが早くキーを押せるのかを競うひどいゲームです。 // 左人差し指と右人差し指が対決する早押しゲーム// プログラミング言語「ドリトル」// インストール版ドリトルで実行してください。// 2020.06.26 蕪木 孝早押し = 0。左指 = ボタン ! "" "ESCAPE" 作る。左指 ! 消える。左指 : 動作 = 「 「:早押し == 0」 ! なら 「:早押し = -10」 そうでなければ 「:早押し == 1」 なら 「:早押

2
素潜りのプログラム

素潜りのプログラム

目標深度を入力してEnterキーを押すと潜り始めます。 このプログラムは次の動画を参考にして書きました。 // 素潜りのプログラム// プログラミング言語「ドリトル」// V3.31以降のインストール版ドリトルで実行してください。// 2020.06.25 蕪木 孝// 参考にした動画 Alessia Zecchini World Record Dive to 102m CWT// https://www.youtube.com/watch?v=1ViCIZjm23

1
スイッチ

スイッチ

プログラミングでスイッチをただ描いただけです。 // スイッチ// プログラミング言語「ドリトル」// V3.31以降のインストール版ドリトルで実行してください。// 2020.06.23 蕪木 孝// ーーーーー 図形オブジェクトのサイズ ーーーーー// 全体のサイズ全体幅 = 478。全体高さ = 204。// 本体のサイズ本体幅 = 346。本体高さ = 204。// スクリーン外枠のサイズスクリーン外枠幅 = 324。スクリーン外枠高さ = 192。// スクリー

1
駅名だけの鉄道シミュレーター

駅名だけの鉄道シミュレーター

日本には行ったことが無い場所がまだたくさんあるなぁ、と思うための鉄道シミュレーターです。 後にプログラムと実行方法を記載しています。 プログラム実行後にまず都道府県を選択します。 選択した都道府県の路線を選択します。 始発駅が表示されます。 Enterキーを押すと進みます。 駅名だけですが運転席視点で表示されます。 Escキーを押すと次の駅で折り返します。 これがプログラムです。 // 駅名だけの鉄道シミュレーター// プログラミング言語「ドリトル」// V3.31

2