Cisco C841Mでロードバランス

追記
時期的なものかもしれないけど、恐ろしくhome routerが手に入らない…絶対数が足りなすぎる

追記
設定が甘い…下記の通りにしてもうまく動作しないっぽい?
本来の上流であるL12とかにstaticでルート切れば行けると思うんだけど、できればciscoでNAPT(PAT)切りたいんだけど、うまくいかん




前回のRouterOSでPCCの設定をアプライアンスでやって見た感じ

とりあえず構成は以下の通り
予定では上流は Speed Wifi HOME 5G L13とHR01あたりを想定している


C841Mのconfigは以下の通り

RT03#show running-config
Building configuration...

Current configuration : 1109 bytes
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RT03
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
!
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
license udi pid C841M-4X-JAIS/K9 sn FGL20412335
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
!
interface GigabitEthernet0/1
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface GigabitEthernet0/3
 no ip address
!
interface GigabitEthernet0/4
 ip address 10.0.20.254 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/5
 ip address 10.0.10.254 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 ip address 10.0.30.254 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 10.0.10.1
ip route 0.0.0.0 0.0.0.0 10.0.20.1
!
!
!
!
control-plane
!
!
!
line con 0
 no modem enable
line vty 0 4
 login
 transport input none
!
scheduler allocate 20000 1000
!
end

RT03#

という感じでゲートウェイが2つになってるだけ
とても簡単

画像では上流の代わりにIX使って家のLANにnaptしてる

一応上流のIXのconfは以下の通り
NAPTしてるだけ

RT01(config)# show running-config
! NEC Portable Internetwork Core Operating System Software
! IX Series IX2215 (magellan-sec) Software, Version 10.7.18, RELEASE SOFTWARE
! Compiled Oct 25-Tue-2022 12:37:13 JST #2
! Current time Feb 10-Sat-2024 22:29:05 JST
!
hostname RT01
timezone +09 00
!
!
ip route default GigaEthernet0.0 dhcp
ip route 10.0.30.0/24 10.0.10.254
!
!
!
!
!
!
!
!
!
!
!
!
!
device GigaEthernet0
!
device GigaEthernet1
!
device GigaEthernet2
!
device BRI0
  isdn switch-type hsd128k
!
device USB0
  shutdown
!
interface GigaEthernet0.0
  ip address dhcp
  ip napt enable
  no shutdown
!
interface GigaEthernet1.0
  no ip address
  shutdown
!
interface GigaEthernet2.0
  ip address 10.0.10.1/24
  no shutdown
!
interface BRI0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface USB-Serial0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address
!
RT01(config)#
RT02(config)# show running-config
! NEC Portable Internetwork Core Operating System Software
! IX Series IX2215 (magellan-sec) Software, Version 10.7.18, RELEASE SOFTWARE
! Compiled Oct 25-Tue-2022 12:37:13 JST #2
! Current time Feb 10-Sat-2024 22:37:33 JST
!
hostname RT02
timezone +09 00
!
!
ip route default GigaEthernet0.0 dhcp
ip route 10.0.30.0/24 10.0.20.254
!
!
!
!
!
!
!
!
!
!
!
!
!
device GigaEthernet0
!
device GigaEthernet1
!
device GigaEthernet2
!
device BRI0
  isdn switch-type hsd128k
!
device USB0
  shutdown
!
interface GigaEthernet0.0
  ip address dhcp
  ip napt enable
  no shutdown
!
interface GigaEthernet1.0
  no ip address
  shutdown
!
interface GigaEthernet2.0
  ip address 10.0.20.1/24
  no shutdown
!
interface BRI0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface USB-Serial0.0
  encapsulation ppp
  no auto-connect
  no ip address
  shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address
!
RT02(config)#


ブリッジにしているvyosは以下の通り

vyos@vyos-01:~$ configure
[edit]
vyos@vyos-01# show
 interfaces {
     bridge br0 {
         address 10.0.10.100/24
         member {
             interface eth0 {
             }
             interface eth1 {
             }
         }
     }
     ethernet eth0 {
         hw-id 00:15:5d:01:1a:1e
     }
     ethernet eth1 {
         hw-id 00:15:5d:01:1a:1f
     }
     ethernet eth2 {
         address dhcp
         hw-id 00:15:5d:01:1a:20
     }
     loopback lo {
     }
 }
 qos {
     interface br0 {
     }
     interface eth0 {
         egress band10Mbps
     }
     interface eth1 {
         egress band10Mbps
     }
     policy {
         network-emulator band10Mbps {
             bandwidth 10mbit
         }
         network-emulator delay7 {
             delay 50
         }
         network-emulator delay100 {
             delay 100
         }
         network-emulator delay100-loss10 {
             delay 1000
             loss 0
         }
         network-emulator loss01 {
             loss 5
         }
     }
 }
 service {
     ntp {
         allow-client {
             address 0.0.0.0/0
             address ::/0
         }
         server time1.vyos.net {
         }
         server time2.vyos.net {
         }
         server time3.vyos.net {
         }
     }
     ssh {
         listen-address 0.0.0.0
     }
 }
 system {
     config-management {
         commit-revisions 100
     }
     conntrack {
         modules {
             ftp
             h323
             nfs
             pptp
             sip
             sqlnet
             tftp
         }
     }
     console {
         device ttyS0 {
             speed 115200
         }
     }
     host-name vyos-01
     login {
         user vyos {
             authentication {
                 encrypted-password 
                 plaintext-password ""
             }
         }
     }
     syslog {
         global {
             facility all {
                 level info
             }
             facility local7 {
                 level debug
             }
         }
     }
 }
[edit]
vyos@vyos-01#
vyos@vyos-02# show
 interfaces {
     bridge br0 {
         address 10.0.20.100/24
         member {
             interface eth0 {
             }
             interface eth1 {
             }
         }
     }
     ethernet eth0 {
         hw-id 00:15:5d:01:1a:21
     }
     ethernet eth1 {
         hw-id 00:15:5d:01:1a:22
     }
     ethernet eth2 {
         address dhcp
         hw-id 00:15:5d:01:1a:23
     }
     loopback lo {
     }
 }
 qos {
     interface eth1 {
     }
     policy {
         network-emulator band10Mbps {
             bandwidth 10mbit
         }
     }
 }
 service {
     ntp {
         allow-client {
             address 0.0.0.0/0
             address ::/0
         }
         server time1.vyos.net {
         }
         server time2.vyos.net {
         }
         server time3.vyos.net {
         }
     }
     ssh {
     }
 }
 system {
     config-management {
         commit-revisions 100
     }
     conntrack {
         modules {
             ftp
             h323
             nfs
             pptp
             sip
             sqlnet
             tftp
         }
     }
     console {
         device ttyS0 {
             speed 115200
         }
     }
     host-name vyos-02
     login {
         user vyos {
             authentication {
                 encrypted-password 
                 plaintext-password ""
             }
         }
     }
     syslog {
         global {
             facility all {
                 level info
             }
             facility local7 {
                 level debug
             }
         }
     }
 }
[edit]
vyos@vyos-02#


この状態でvyosのnetwork-emulator機能を使って、パケットロスやi/fのリミット制限をかけた際にどういう動きをするのかを検証します。
続く…


この記事が気に入ったらサポートをしてみませんか?